Incoming SMS messages not delivered to some phone numbers
Incident Report for Telebroad
Resolved
We implemented a permanent fix.
Here is our conclusion of the cause of the issue.
At about 10:30 a.m. one of the mobile carriers started sending delivery status reports to our network repeatedly. This very likely occurred due to an error on their network. This caused that the inbound messaging should become full and the system wasn't able to pass a significant increase of requests at once. Therefore the messages were placed in a queue.
We have reached out this mobile carrier. Their engineers have implemented a quick fix. However, while trying to clear the queued messages, some messages may have been received repeatedly because the sending carrier didn't receive the message acknowledgment when the request was made first attempt. The issue is now resolved.
Posted Aug 30, 2022 - 16:26 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2022 - 15:38 EDT
Identified
Messages are coming in now but with delays we are still working to resolve this issue completely.
standby for updates.
Posted Aug 30, 2022 - 14:12 EDT
Investigating
We are currently investigating complaints that some numbers do not receive incoming messages.
standby for updates.
Posted Aug 30, 2022 - 12:32 EDT
This incident affected: TeleBroad SMS.