Error sending efax
Incident Report for Telebroad
Resolved
This has been resolved.
Posted 29 days ago. Sep 23, 2019 - 13:08 EDT
Identified
We've received error reports when trying to send an efax. This feature seems to have broken during our upgrade last night & a quick fix is currently being worked on.

It ONLY affects OUTBOUND eFax, Incoming faxes should still work uninterrupted.
Posted 29 days ago. Sep 23, 2019 - 12:37 EDT
This incident affected: TeleBroad FAX.