No incoming calls to iPhone Teleconsole App
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted about 1 year ago. Apr 26, 2018 - 19:45 EDT
Investigating
We're getting reports of issues with incoming calls to the TeleConsole iPhone App (only.. Android App working well). We're checking!
Posted about 1 year ago. Apr 26, 2018 - 16:38 EDT