Verizon wireless customers in NYC metro Area having issues reaching Telebroad customers,
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted Jan 05, 2023 - 14:42 EST
Monitoring
According to Verizon a fix has been applied and they are now monitoring the results.
Posted Jan 05, 2023 - 12:58 EST
Update
Verizon is currently investigating this issue internally. We have escalated this case with all of our contacts and will continue to follow-up with them for further updates.

Thank you,
TeleBroad NOC
Posted Jan 05, 2023 - 11:57 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 05, 2023 - 11:47 EST
Identified
We are aware that some Verizon wireless customers in NYC metro Area having issues reaching Telebroad customers, we are working with Verizon to resolve this issue.
Posted Jan 05, 2023 - 11:45 EST
This incident affected: TeleBroad PBXCELLENT.