Users having Issues to to use the app & admin center
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted Sep 26, 2023 - 14:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2023 - 13:46 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 26, 2023 - 13:25 EDT
This incident affected: TeleBroad SMS, TeleBroad API, and app.telebroad.com.