Issue with "outbound" eFaxing (affecting email2fax only)
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 18, 2019 - 01:16 EDT
Update
We are continuing to investigate this issue.
Posted 3 months ago. Apr 18, 2019 - 01:16 EDT
Investigating
Use our eFax alternative methods {example Print to FAX or Teleconsole}
Posted 3 months ago. Apr 17, 2019 - 12:24 EDT
This incident affected: TeleBroad FAX.