Reports of Issues making/receiving calls at 6:25PM EST,
Incident Report for Telebroad
Resolved
Appears to be a major disruption at our main Brooklyn datacenter. We forced backup to our second Datacenter. All services appear to be running smoothly again now.
Posted over 1 year ago. Dec 19, 2017 - 18:32 EST
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Dec 19, 2017 - 18:28 EST