Static calls to some destinations
Incident Report for Telebroad
Resolved
The underlying carriers confirmed to have resolved this issue. It has been tested and confirmed to be resolved at this point.
Posted 3 months ago. Aug 08, 2019 - 17:51 EDT
Investigating
We've recieved reports of static voice issues when calling to certain destinations. We're working with selected carriers to resolve this issue and will post updates as they come.
Posted 3 months ago. Aug 08, 2019 - 14:25 EDT
This incident affected: TeleBroad PBXCELLENT.