Issue with "outbound" eFaxing (affecting Print2Fax & email2fax)
Incident Report for Telebroad
Resolved
Issue was related to an underlying carrier we use for high quality outbound fax lines. Service was fully restored moments ago.
Posted almost 2 years ago. Nov 05, 2017 - 01:28 EST
Investigating
We're getting reports of issues SENDING [outbound only] faxes using Print2Fax & email2Fax.
Posted almost 2 years ago. Nov 05, 2017 - 01:21 EDT