Issues with making/receiving calls
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted over 1 year ago. Oct 24, 2017 - 13:47 EDT
Monitoring
Issue identified & fixed. We're monitoring...
Posted over 1 year ago. Oct 24, 2017 - 12:45 EDT
Update
This issue is intermittent and should not affect calls already in progress.

Should be fully resolved shortly.
Posted over 1 year ago. Oct 24, 2017 - 12:32 EDT
Investigating
Customer reporting trouble making/receiving calls.
Posted over 1 year ago. Oct 24, 2017 - 12:24 EDT