"outbound" eFaxing issue affecting email2fax & print2fax
Incident Report for Telebroad
Resolved
This was resolved by our engineers at around 2am
Posted over 1 year ago. Jan 15, 2018 - 09:03 EST
Investigating
We're receiving reports of error messages received when "sending" outbound faxes using Print2Fax & Email2Fax, reading "user do not exists" or "error with username/password".
Posted over 1 year ago. Jan 14, 2018 - 22:56 EST