Outbound Calling issues to T-mobile network
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted Jun 16, 2020 - 09:20 EDT
Identified
We have received multiple complaints about not being able to call certain phone numbers,
We have identified that dose calls are to mobile numbers operated by T-mobile, which confirmed to have a system outage,

thank you, we will monitor and post updates
Posted Jun 15, 2020 - 15:46 EDT
This incident affected: TeleBroad PBXCELLENT.