Users have issues to sign in to the app and admin center
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted Jul 25, 2023 - 17:21 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 25, 2023 - 15:49 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 25, 2023 - 15:49 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 25, 2023 - 15:42 EDT
This incident affected: TeleBroad API, app.telebroad.com, and Mobile Apps (iPhone & Android).