Partial outage affecting ACD and Teleconsole
Incident Report for Telebroad
Resolved
Status resolved.
Posted 11 months ago. Aug 20, 2018 - 12:23 EDT
Identified
Identified intermittent issue affecting ACD dashboard and Teleconsole. Resolution in progress.
Posted 11 months ago. Aug 20, 2018 - 12:02 EDT
This incident affected: TeleBroad ACD Dashboard and app.telebroad.com.