Issues with Toll Free incoming calls
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 29, 2019 - 15:13 EDT
Investigating
We're receiving reports of issues with INCOMING calls to customer TOLL FREE numbers.
Posted 5 months ago. Apr 29, 2019 - 11:28 EDT
This incident affected: TeleBroad PBXCELLENT.