Reports of issues with incoming faxes...
Incident Report for Telebroad
Resolved
Issue has been identified & resolved...
Posted about 2 years ago. Apr 26, 2017 - 09:57 EDT
Investigating
We are currently investigating this issue.
Posted about 2 years ago. Apr 26, 2017 - 09:50 EDT