Issue making/receiving calls
Incident Report for Telebroad
Resolved
Issue resolved. postmortem report will be updated at end of business day today.
Posted almost 2 years ago. Jul 24, 2017 - 13:46 EDT
Monitoring
Most affected customer already restored. Monitoring..
Posted almost 2 years ago. Jul 24, 2017 - 13:12 EDT
Investigating
Partial outage still....
Posted almost 2 years ago. Jul 24, 2017 - 12:58 EDT
Identified
Issue seems to be resolved for now. Details to follow.
Posted almost 2 years ago. Jul 24, 2017 - 12:50 EDT
Investigating
We're checking
Posted almost 2 years ago. Jul 24, 2017 - 12:47 EDT