Issues making/receiving calls
Incident Report for Telebroad
Resolved
The issue has been identified and resolved.
Posted Aug 10, 2020 - 09:50 EDT
Investigating
We are currently investigating this issue.
Posted Aug 10, 2020 - 09:44 EDT
This incident affected: TeleBroad PBXCELLENT and Mobile Apps (iPhone & Android).