Issues with call audio
Incident Report for Telebroad
Resolved
This issue has now been resolved. We'll post a full update shortly.
Posted Dec 16, 2019 - 10:17 EST
Monitoring
A fix has been implemented and we are monitoring the results. (Not resolved yet)
Posted Dec 16, 2019 - 09:52 EST
Investigating
We're getting reports issues while making and receiving calls.
Posted Dec 16, 2019 - 09:24 EST
This incident affected: TeleBroad PBXCELLENT.