Issue sending eFaxes
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted about 2 years ago. Aug 24, 2017 - 15:46 EDT
Monitoring
Appears to be resolved, but we're still monitoring for any recurring errors.
Posted about 2 years ago. Aug 24, 2017 - 13:18 EDT
Investigating
We received reports of errors while attempting to send an eFax/Print2Fax. Checking...
Posted about 2 years ago. Aug 24, 2017 - 12:40 EDT