Major outage
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted Jun 03, 2022 - 14:00 EDT
Update
Issue resolved. We'll post post incident updates shortly.
Posted Jun 03, 2022 - 13:55 EDT
Investigating
We are currently investigating reports or an outage
Posted Jun 03, 2022 - 13:43 EDT
This incident affected: TeleBroad PBXCELLENT, TeleBroad API, app.telebroad.com, and Mobile Apps (iPhone & Android).