API server issue affecting many services
Incident Report for Telebroad
Resolved
We've identified the server rejecting all logins and corrected the issue.
Posted Nov 16, 2020 - 09:48 EST
Investigating
We are currently investigating this issue.
Posted Nov 16, 2020 - 09:41 EST
This incident affected: TeleBroad ACD Dashboard, TeleBroad API, and Mobile Apps (iPhone & Android).