Issue with "outbound" eFaxing (affecting email2fax only)
Incident Report for Telebroad
Resolved
Fixed. All faxes that were queued, will be delivered now...
Posted about 2 years ago. Jul 31, 2017 - 13:57 EDT
Investigating
We're getting reports of issues sending Outbound faxes via email. Checking...
Posted about 2 years ago. Jul 31, 2017 - 13:49 EDT