Issues logging in to Web & Mobile Apps
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted about 1 year ago. May 30, 2018 - 13:43 EDT
Investigating
We're receiving reports of issues logging into some of our Cross platform apps, such as Mobile & Web.

We're investigating
Posted about 1 year ago. May 30, 2018 - 11:59 EDT
This incident affected: TeleBroad ACD Dashboard, TeleBroad SMS, TeleBroad API, and app.telebroad.com.