DTMF Issues with incoming calls to some numbers
Incident Report for Telebroad
Resolved
We've worked with the underlying carriers to clear this issue. We can now confirm this has been resolved.
Posted 2 months ago. Aug 23, 2019 - 09:48 EDT
Investigating
We're receiving reports of issues with INBOUND calls to some numbers that point to an IVR greeting that callers are unable to make their choices by pressing any digits (this is known as a DTMF issue).
Posted 2 months ago. Aug 23, 2019 - 09:17 EDT
This incident affected: TeleBroad PBXCELLENT.