Issues opening ACD panel
Incident Report for Telebroad
Resolved
This incident has been resolved.
Posted about 1 year ago. Aug 12, 2018 - 03:19 EDT
Investigating
We are currently investigating this issue.
Posted about 1 year ago. Aug 10, 2018 - 15:28 EDT
This incident affected: TeleBroad ACD Dashboard.