Phones and Apps unable to connect
Incident Report for Telebroad
Postmortem

An electrical issue affecting multiple providers in our data center has briefly disrupted our upstream internet connection.

We're working to mitigate such issues in the future - for now, they were resolved by manually rerouting the traffic.

Posted Jul 04, 2021 - 11:27 EDT

Resolved
As of 8:30 - many phones are unable to connect to make or receive calls. Apps are down as well. We're investigating
Posted Jul 04, 2021 - 08:30 EDT